I suggest you ...

Make sessions run in it's own thread

What I notice on Windows is that when I open more than one ssh session that's constantly having terminal activity (logs or htop), that other sessions start lagging quite badly. If I close those active sessions it's back to normal. If each session would start under it's own thread I'd never have this issue. It's quite annoying to have to close and reopen sessions just because terminal text in other sessions affect a different one.

7 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Dwayne Hulsman shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base