How can we improve the iOS app?

[Troubleshooting] - SSH Agent Forwarding not working anymore

Hi, since one of the latest Updates (I don't keep track of them, sorry, I can't point out exactly which one),
the ssh agent forwarding isn't working like it used to.
I can connect to the first host, but when I attempt to ssh to the next host, I either
- get asked for the Password
- get a "Permission denied (publickey)
- get a "key_from_blob: invalid format.

I tried importing openssh and putty-style formatted keys.
I enabled and disabled the Agent forwarding, in the global options as well as in the host-options, nothing works so far.

In the update notes, I read something about an improved ssh-Agent, I think I'm missing something, but can't find the issue.
Pleas help!

29 votes
Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Hans shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Comments are closed
  • Serge Pluess commented  ·   ·  Flag as inappropriate

    I have just purchased Termius for the promise of agent forwarding, only to find out that it doesn't work. After connecting to the first host and trying to the following host I get the error message:

    Agent admitted failure to sign using the key.

    I just tested with the android version and agent forwarding works as expected, but my main platform usage is for iOS. So at the moment the app is pretty much useless to me and am testing other apps. This happened on iOS 11 and on iOS 10.3.3.

  • Hans commented  ·   ·  Flag as inappropriate

    Before you mention it, I' using the Premium Version, and it worked perfectly before :) , and still does on every other device with various Clients (SecureCRT,Putty,ssh(debian)).

Feedback and Knowledge Base