How can we improve the iOS app?

[Major bug] The iOS App won't start a new terminal?

I just downloaded the app and added a new host. Then I go to Terminals -> Search or type command -> Tap on the recently added: 'mosh MyServer -p 22'.

Nothing happens.

I try typing this manually and tapping 'Connect'.

Nothing happens.

Am I doing something wrong? How do I ssh into a server? It looks like the app is just completely broken...

4 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Peter Livesey shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Reviewing  ·  AdminTermius Support (Admin, Termius) responded  · 

    Hello,
    Thank you for the feedback.
    Please contact us through Help & Feedback → I’ve Got a Question form so we could investigate the case more carefully.

    Also please note that there may be several reasons for such behaviour.

    First most common reason is that your host may be unreachable from the network that your iOS device is using.

    Please none that since you are using mosh you should make sure that mosh server is installed on your host. Also when you are using mosh via ‘Terminals → Search or type command’ field Termius will use default mosh ports and mosh command (-p 22 is for initial SSH connection to launch mosh, not mosh it self). You may need to change mosh command.

    To do that please create Host item at Hosts screen and make corresponding configurations there (to change mosh settings please enable ‘Use SSH’ and ‘Use Mosh’ switch when configuring host record)

    Also it may be that your host or a firewall is blocking incoming connections to port 22 or that your host has different port for SSH connections.

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • John Purcell commented  ·   ·  Flag as inappropriate

        UPDATE/SOLVED: After receiving the email response from support (thank you), I did discover that my iPad had chosen a wireless network that cannot reach the target. Nice to know my network segregation is working! Upon remedying that error and telling the host setup to use a key file (again!) I was able to connect. Had I received feedback such as "host not found" I'd have known immediately what the problem was. Clearly I was employing "user error", but people make mistakes and clear feedback/response is key to remedying. My issue is solved.

      • John Purcell commented  ·   ·  Flag as inappropriate

        I get the exact same behavior. I am a new user and just installed Terminus 4.0.6 on my iPad, configured a host to connect via ssh using a key I imported using iTunes, edited the key to supply the passphrase. Tapping the newly defined host, nothing happens. Actually the lines orbit the icon for about a minute then stop. No connection, no error message, no terminal, no log.

        Similar with terminal command line. No connection, no error.

        Dying silently is not good.

        (in case you are wondering, yes I've been able to successfully establish connections to the target from a Mac using SSH on command line and from a Windows 7 system using PuTTY.)

      • Peter Livesey commented  ·   ·  Flag as inappropriate

        If I go to hosts and tap on the host, then the detail text says:

        Connecting...

        And then it goes back to `ssh, ubuntu`

      Feedback and Knowledge Base