How can we improve the iOS app?

V4.0.9 won't update or install on iOS 9.3.5

Provide support for iOS 9.3 machines

34 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

12 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Ant commented  ·   ·  Flag as inappropriate

    Finally the upgrade error message is gone, but app requires iOS v10.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Heads up for those like me on ios 9.3.5: if you uninstall the app, you can no longer reinstall it. The standard incompatibility message is displayed when you try.

    Tired of dropped support for devices that work perfectly. After all, they are only made to do simple stuff browse the web, watch movies, ssh to other devices... There is no need for high performance...

  • Arjan commented  ·   ·  Flag as inappropriate

    Not only does it fail to update on ipad4, the message about downloading a last compatible version also blocks other apps from (auto-)updating if they are listed below Termius in the Updates tab of the App Store. So either fix it or remove it as update on these older devices so the other apps can update normally.

  • Arjan commented  ·   ·  Flag as inappropriate

    Pls build the 32 bit version again. App will not update on iPhone 4s, iPhone 5, iPad 2, iPad 3 or iPad 4.

  • Pi Man commented  ·   ·  Flag as inappropriate

    Description in AppStore still says it works with iOS 9.3 or later.

Feedback and Knowledge Base