How can we improve the iOS app?

Version 4.1.0 fails to connect with “Private key is not selected”

I can’t connect via ssh with a username and password anymore. I am not using keys at all. I have an iPhone XS on 12.1.

29 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

12 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Melody Nelson commented  ·   ·  Flag as inappropriate

    I have this error on TestFlight 4.2.0 right now. I even tried to reinstall and start fresh - no luck. I add a host, select ssh, port, username, password, try to connect and it says Private key is not selected.

  • Frank Phoenix Schroeder commented  ·   ·  Flag as inappropriate

    I have the same issue on my iPAD.
    I tried with the version in Testflight and the connections work again
    I would be important to mention that you have to delete the old version before installing the one from testflight as else you get the following:
    You just get unrecoverable error, sync is gone after every start and no connection at all is possible as nothing happens while clicking on the different server connections.

  • Tonto commented  ·   ·  Flag as inappropriate

    Had the same issue with all but one hosts. So I gave the beta build a try. It is a nightmare. Takes ages to load, loses all saved connections and keys, is very sluggish and won‘t even try to connect to anything. I can tap a host all I want and nothing happens. Only asks me which protocol to use if I didn‘t specify one in the hosts settings but no actual connection attempt.

  • AdminTermius Support (Customer Success Manager, Termius) commented  ·   ·  Flag as inappropriate

    Hey, thanks to everyone who helped us to investigate this issue, we've been able to reproduce and fix it. We are going to share new beta build in Testflight later today. To get access to the build please use this link https://testflight.apple.com/join/MnuClabg

    This update will be available on the App Store as soon as it passes the review.

  • yo commented  ·   ·  Flag as inappropriate

    I had same case on iPhoneX(iOS12), Waiting for new update.
    Thanks!

  • Sören Lannermo commented  ·   ·  Flag as inappropriate

    Same issue for me. I can not connect to any of my CentOS hosts. Connection to a MacOS host still works. iPhone 7/iOS 12.1.

Feedback and Knowledge Base