How can we improve the iOS app?

pem file support?

How can I load a pem file (e.g. from AWS) into Termius on iPad?

25 votes
Sign in
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
Gary Hooper shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Reviewing  ·  AdminTermius Support (vcc, Termius) responded  · 


This actually should work. You just need to copy the content of the pem file to the private part of the key when copying it into Termius app in the Keychain section.

We’ll double-check it.

If you have any other problems please contact us here –



Sign in
Password icon
Signed in as (Sign out)
  • Erdinc Keloglu commented  ·   ·  Flag as inappropriate

    not working for linux version, too. i'm on ubuntu 18.04.1 LTS. when i import pem key, it asks for a password and cant login.

  • Anthony commented  ·   ·  Flag as inappropriate


    It prompted me for a password because I entered, within the Termius host configuration, the user as ec2-user@<fqdn>. Termius also appends the fqdn to the user name so it ended up getting appended twice. It shows you the username it used in the pop up when it asks for the password.


  • Dave commented  ·   ·  Flag as inappropriate

    This doesn’t directly answer the question here but I can describe the successful process I used to be able to setup Termius on an iPad to access an AWS instance.

    First create an RSA key in Termius. The type must be RSA, size can be anything and you can add a pass phrase if you like. Next you need to ‘Copy Public Key’.

    Now go to your AWS console. Under Network & Security > Key Pairs click the ‘Import Key Pair’ button. Give the key a name and paste the public key in the large text box.

    Now, still in the AWS console create your instance. When setting up security use the key you just added. Make a note of the instance details (username & hostname).

    Back in Termius add the host with the noted details. Remember to setup the host to use the key you created.

    That’s it. You should be able to log in now. At least I was when using this process.

  • Tommy commented  ·   ·  Flag as inappropriate

    I tried on Mac OS, it still don't work with pem file after I added into Performances/KeyChain

  • Charly Arg commented  ·   ·  Flag as inappropriate

    I can confirm that I converted my .ppk from putty to .pem using puttygen, and then I opened the .pem file with Textedit, copied and pasted over the private key in the keychain in Termius and it worked perfectly!

  • Tommy commented  ·   ·  Flag as inappropriate

    Can't find a way to add pem file into Termius Mac version, ideally, the user should able to drag pem file to the keychain in the performance of Termius Mac app. hope it will be supported soon.

  • zzoi commented  ·   ·  Flag as inappropriate

    1. Link your iPad with PC where .pem file installed.
    2. Open iTunes and click iPad -> File Sharing
    3. Click 'Termius' from the list then you can put your '.pem' file at the right side.
    4. Go to Termius and open keychain then '.pem' file will show up

  • Danny commented  ·   ·  Flag as inappropriate

    Tried with every possible combination (with opening and closing line, without it, etc.) but still getting the error "unsupported key format"

  • Kfir commented  ·   ·  Flag as inappropriate

    It worked for me, as they have instructed, just make sure you copy the contents of the pem file TOGETHER WITH the opening and closing line (" -----BEGIN RSA PRIVATE KEY-----"...)

  • jordan commented  ·   ·  Flag as inappropriate

    same issue. unsupported key format. Need a way to point to a .pem file.

  • Jon Plotter commented  ·   ·  Flag as inappropriate

    I added the RSA key to the keychain. I selected it after. Yet when I connect, I am asked for the password. Is there anything wrong with what I am doing?
    ( I saved the key in the password field also - same result)

  • Anonymous commented  ·   ·  Flag as inappropriate

    Open your pem file with any text editor and paste it to add keychain page, which is your termius preference. Then you can select on adding host page.

  • Chad T commented  ·   ·  Flag as inappropriate

    Does copy and paste not work for you? That's how I got mine imported.

Feedback and Knowledge Base