How can we improve the iOS app?

Smart Keyboard can not work well

When using emacs,C+M+> did not work. And when I press C+f,the cursor move forward just one word.

9 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • jaa commented  ·   ·  Flag as inappropriate

        I just checked, and with the iPad Pro and the smart keyboard, I have no problem using the 'option' key as the 'alt' key.

        I did nothing to configure this.

        It works both at the shell command-line, and emacs.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Mi current workaround is use Emacs's feature of emulating Alt via Escape. Basically the problem with the Smart Keyboard is that any key "chord" involving Alt doesn't work unless Alt is the control key. For that, I first tell Emacs to Alt by pressing Esc (which by itself is a problem with the Smart Keyboard, but can be input via Cmd + `), then I can do whatever I want. Yes it makes things uncomfortable but its a workaround to unlock you. Still I gave 3 of my 8 votes available to this because the workaround itself is a pain.

      Feedback and Knowledge Base