How can we improve the iOS app?

Fix so that it remembers fingerprints for FreeBSD servers

I use Termius to connect to three hosts; one running OpenBSD 5.8, one running Debian 8.10 and one running FreeBSD 11.1.

Connecting to the OpenBSD and Debian hosts work perfectly, and in the hosts list their entries also show that Termius has recognized what operating system they are running.

When connecting to the FreeBSD server Termius always states that it can’t establish the authenticity of the host. The fingerprint is always the same so it’s a problem with Termius. I’ve not had any problems like this connecting to my server from my desktop computer running OpenSSH client.

The only thing that is different about the setup of SSH on my FreeBSD server from the default settings is that I’ve disabled password login.

I am able to log in with the public key I generated in Termius but it’s very annoying that it is not able to remember the fingerprint.

Feel free to contact me if you have any questions. I’ve filled out my e-mail address in the field below.

3 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Erik N shared this idea  ·   ·  Admin →

    1 comment

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Erik N commented  · 

        Actually come to think of it I don’t even have password authentication disabled currently so al the settings for the OpenSSH server are at their defaults.

      Feedback and Knowledge Base