How can we improve the Android app?

Fix copy and paste across multiple lines

Copying text that spans multiple lines in a terminal does not subsequently work correctly when pasted. It appears to add an unnecessary line break and other characters. Much like the old windows command line used to.

5 votes
Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Phil Ayres shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Comments are closed
  • Mark Kampe commented  ·   ·  Flag as inappropriate

    I tried termius because I just got a Kindle and Amazon does not seem to offer ConnectBot (or IRSSI ConnectBot) ... which I like because of how well they work with bluetooth keyboards.

    Obviously, the first thing I tried to do was get some new ssh keys imported into termius.
    I tried copying them from local files, but I couldn't browse to the directories that contained them. Then I decided to open a session, cat the files, and paste them into termius. I had great difficulty getting it to copy. Taps mostly got me an offer to paste. Many taps with random pauses in between, many times and I get it one time in ten.

    I was doing the copy so that I could paste a public and private key, but (a) leaving the add key dialog to copy the other key exited the dialog and (b) after I finally decided to copy everything (public and private) and then edit them within the key entry dialog, it still would not create the new key (no error message, just no key there when I was done).

    Finally I decided to just let you generate a key, which I would distribute. That worked fine (after I figured out how to edit/view an existing key).

Feedback and Knowledge Base