How can we improve the Desktop app?

Unable to use Alt-Gr keyboard keys (QWERTZ keyboard)

On QWERTZ keyboard with Alt-Gr keys, characters that use that key cannot be entered into the terminal (most notably ~\}@)
Inputting does nothing except for ~ which triggers a zoom.

This does work on other Electron apps -- please help.

Keep up the great work!

34 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

8 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • fritzmg commented  ·   ·  Flag as inappropriate

    Same problem here. However, weirdly it does not happen on all of my 3 systems, just on one.

  • Clemens commented  ·   ·  Flag as inappropriate

    any suggestions or solution yet?

    app isn't practicable when you cannot use special keys

  • Emilio Castro commented  ·   ·  Flag as inappropriate

    I can confirm that I'm having this issue as well, it's very frustrating having to type the special characters (@~^`\) somewhere else and pasting it, especially if I'm in a hurry and want to send commands fast

  • Anonymous commented  ·   ·  Flag as inappropriate

    On a Portuguese keyboard, I cannot type the } (AltGr+0) and € (AltGr+E) characters. This app has plenty of issues on Windows, but the fact that I cannot type } is the only thing that is preventing me from purchasing it. Please fix asap.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same story on croatian keyboard - I can not find way how to get pipe and backslash (AltGr+Q, AltGr+W)
    On iPad Termius is miles ahead of competition, but unusable for me on Win10. Pitty.

  • Elvio commented  ·   ·  Flag as inappropriate

    App desktop v2.0.1 unable to use alt+gr characters (@,#,...)

Desktop App

Feedback and Knowledge Base