How can we improve the Desktop app?

BUG: Private key asking for passphrase when shouldn't

Yesterday I was using Termius just fine... this morning (8/13/18) it updated to v3.0.4 and now all of a sudden, I'm being asked for a passphrase when I use a private key. Using the same key on Putty connects successfully.

Your software offers no option for rollback so now it is completely useless to me.

17 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Graham Pinkston shared this idea  ·   ·  Admin →

    10 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Bojan Bugarski commented  · 

        Version 3.1.4 (3.1.4) - OSX HighSierra - same thing
        my key doesn't have a passphrase but I am prompted for one

      • Raymond De Castro commented  · 

        I'm also experiencing this. My key doesn't have a passphrase but it is asking for one.

      • Rohman Muhamad commented  · 

        Hi guys, i think this problem also happened to me. My configuration just fine and working on Termius Ubuntu 18.04. but it keeps asking me for a password everytime when i try to login using private-key, even when i set the right password, the prompt keep showing.

      • Anonymous commented  · 

        3.1.5 Windows
        SAME STORY!

      • Anonymous commented  · 

        3.1.4 on Mac, the same bug.

      • Juliano Silva commented  · 

        HI

        I am having the same problem in version 3.0.9 very sad for me with this problems, I would like to block updates

      • AdminTermius Support (Admin, Crystalnix Limited) commented  · 

        Hello,

        Thanks for reaching out and sorry for the inconvenience.

        We've just released the 3.0.5 version which should fix the problem you have.

        Could you please check that everything works well for you now? If it doesn't, please let us know which type of key you are using to connect to the servers.

        Thanks in advance and we're looking forward to hearing from you.

      • Anonymous commented  · 

        I have the same problem.. I am using keys that have never had passphrase set. No matter what I add for the public/private fields, termius asks for passphrase every time I try and connect

      • Anonymous commented  · 

        I have the same problem. I can't use termius anymore. Keeps asking for passphrase. Even if I enter teh correct one I can't login.

      Feedback and Knowledge Base